Multiple Issues with Cyber Risk Platform
Incident Report for UpGuard CyberRisk
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 19:53 UTC
Update
All issues have been resolved and are operating as expected.
Posted Jul 19, 2023 - 19:53 UTC
Update
We have implemented a fix for the questionnaire issues and are still investigating our manual re-scans.
Posted Jul 19, 2023 - 19:40 UTC
Update
We are continuing to investigate this issue.
Posted Jul 19, 2023 - 18:47 UTC
Update
We've identified multiple issues within the platform at the moment.

Manual rescans don't complete - this issue has been diagnosed and and a fix being applied.
Questionnaires cant be created or copied
The release notes link on the home page doesn't work correctly

The issues are still under active investigation to determine root cause.
Posted Jul 19, 2023 - 17:04 UTC
Update
A further issue has been detected where manual rescans are also failing.
We are working on resolving both issues, and to determine if these are separate incidents or with the same root cause.
Posted Jul 19, 2023 - 16:41 UTC
Update
We are continuing to investigate this issue.
Posted Jul 19, 2023 - 16:08 UTC
Investigating
There are currently issues within the Questionnaire Library module resulting in the failure to copy or duplicate questionnaires. We are currently investigating the issue.
Posted Jul 19, 2023 - 16:06 UTC