A database outage is causing the platform to be unavailable

Incident Report for UpGuard CyberRisk

Resolved

This incident is now resolved.
The database ran out of connections due to a lock being held as part of the fortnightly release. Changes to the release process are being implemented to remove the risk of this happening again.
Posted Sep 23, 2026 - 02:41 UTC

Monitoring

The database restart has successfully restored the platform. We are monitoring, and checking for a root cause.
Posted Sep 23, 2026 - 02:05 UTC

Identified

We have restarted the database. We are continuing to investigate.
Posted Sep 23, 2026 - 02:00 UTC

Investigating

We are currently investigating.
Posted Sep 23, 2026 - 01:55 UTC
This incident affected: UpGuard CyberRisk (Web App, External API, Authentication).