Disruption to notification emails

Incident Report for UpGuard CyberRisk

Resolved

The incident is now resolved. All delayed notifications have now been sent.
Posted Jul 09, 2026 - 01:10 UTC

Monitoring

New notification emails are now being delivered as expected. Previously delayed notifications are still being processed and may take some time to arrive.
Posted Jul 08, 2026 - 21:52 UTC

Identified

We’ve identified an issue with our email service provider that is delaying delivery of some notification emails.

Our team is working with the provider to restore normal processing. In-app functionality is not affected, but some email notifications may be delayed until processing resumes. Our engineering team is also working towards an alternative solution.
Posted Jul 08, 2026 - 21:29 UTC

Investigating

We are currently investigating a delay/disruption in processing notification emails.
Posted Jul 08, 2026 - 17:52 UTC