We are experiencing an issue where the platform will be offline for a period of time.

Incident Report for UpGuard CyberRisk

Resolved

Our engineers have identified the issue, and it's been fully resolved. The platform is fully functional.
Posted Mar 06, 2026 - 01:52 UTC

Investigating

We are aware of an issue impacting certain features, including the trust page, questionnaires, and user role adjustments. Our engineers are investigating and working on a solution which requires a temporary shut down of the platform.
Posted Mar 06, 2026 - 01:30 UTC
This incident affected: UpGuard CyberRisk (Web App, External API, Authentication).