An issue has been identified where questionnaires are unable to be sent.

Incident Report for UpGuard CyberRisk

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 19:32 UTC

Update

The issue has been resolved.
Posted Sep 05, 2025 - 19:32 UTC

Update

We have identified a backlog in our async jobs queue and are working towards a fix.
Posted Sep 05, 2025 - 19:30 UTC

Investigating

We are currently investigating.
Posted Sep 05, 2025 - 19:12 UTC
This incident affected: UpGuard CyberRisk (Web App).