An Issue has been identified regarding a disruption to login services.

Incident Report for UpGuard CyberRisk

Resolved

The incident is now resolved. All login has been resumed.
Posted Aug 10, 2026 - 05:09 UTC

Identified

We’ve identified an issue with our login service that is affecting users authentication.
Posted Aug 10, 2026 - 04:58 UTC
This incident affected: UpGuard CyberRisk (Authentication).